[FIXED] Can't activate the game

[FIXED] Can't activate the game

Postby GatekeeperCruelman » 17 August 2012, 09:06


I've bought Faery Legends of Avalon on gamestop. After the download and the install where finished I've tried to start the game and then the activation managers pops up. When the manager asks for my key I've pasted my game key and presses on next. Now it tries too activate the game but instead the next error message comes after waiting ten to twenty seconds: Error (1000) Connection failed. Please check your internet connection.
I've tried it several times now (in the mean while I've registered on this forum and I'm writing this post). I've put the proxy from "Automatic proxy detection" too "Do not use proxy server" after I've got the error several times.
Hopefully someone can help me, otherwise this was a waste of money and time.

Thanks in advanced

Posts: 1
Joined: 17 August 2012, 08:55

Re: Can't activate the game

Postby The_deceased » 21 August 2012, 13:28

Not many ppl check the forums nowadays lol You should message the developers/technical support, or try finding out a solution somewhere else as this error might be a common one with other titles :) (yup I know that I'm completely useless :P ).
Posts: 65
Joined: 21 April 2011, 22:14

Re: Can't activate the game

Postby FocusTechSupport » 24 August 2012, 13:53

Please install the protection patch.
Posts: 20
Joined: 29 September 2010, 15:47

Return to Technical Forum

Who is online

Users browsing this forum: No registered users and 1 guest